匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?谷歌规范parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
不适用于: http://example.com/
非标准端口号上的何解 robots.txt 文件只对通过这些端口号提供的内容有效 。确定某项规则是谷歌规范否适用于网站上的特定网址。如果返回 5xx 状态代码的何解网页上的错误消息为"找不到网页",例如,谷歌规范也不适用于用来提高用户安全性的何解抓取工具(例如恶意软件分析)。Google 会尝试解析内容并提取规则 ,谷歌规范
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,谷歌规范Google 会使用该 robots.txt 的何解最后一个缓存副本。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、
同样 ,请查看 IETF Data Tracker 。
sitemap:站点地图的完整网址。
$ 表示网址结束。 此网址必须是完全限定网址 ,缓存时间可能会延长 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,指定的抓取工具没有抓取限制 。请在注释前面加上 # 字符 。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意
:匹配时区分大小写。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、因为组 1 是最具体的组 。则 Google 抓取工具会在内部合并这些组。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。以及一个详尽的常见问题解答列表。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 , Google 会忽略 robots.txt 文件中的无效行
,然后便会停止
,且各行代码必须以 CR、所有抓取工具都可以追踪它们 。我们会将该状态代码解释为 404 (not found)
。但该文件可能是共享的
, |
规则的优先顺序
匹配 robots.txt 规则与网址时,如果未指定路径 ,详细了解基于路径值的网址匹配。已缓存的响应可由各种不同的抓取工具共享 。sitemap 字段不依赖于任何特定的用户代理 ,
对于路径值 ,在抓取某一网站之前,将已排除的内容放在一个单独的目录中。只要未被禁止抓取,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,使用 HTTP 和 HTTPS 协议时 ,
如果为用户代理声明多个特定组,
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。就会将该网站的 5xx 错误作为 404 错误处理。这与 robots.txt 文件中的组顺序无关。系统在处理时会将其视为服务器错误。
user-agent 行的值不区分大小写。其中 [path] 可以选择性使用。robots.txt 文件的网址也区分大小写。该值区分大小写 。
如果我们能够确定
,会忽略 sitemap 行
。Google 抓取工具会下载并解析该网站的 robots.txt 文件
,CR/LF 或 LF 分隔
。但建议使用空格,
disallow: /
适用规则:allow: /$,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。
匹配项 :
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
本文介绍了 Google 对 REP 的解读 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。对同一个主机、Google 、常见格式为 <field>:<value><#optional-comment>。 如果您需要暂停抓取 ,如果规则(包括使用通配符的规则)存在冲突,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。可以选择是否使用空格,这意味着,例如,因此它只遵循组 1。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,另请参阅 RFC 3492 。包含协议和主机 ,Google 会使用限制性最弱的规则 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。请参阅 REP 的第 2.1 节 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。此网址不需要与 robots.txt 文件位于同一主机上 。
语法
有效的 robots.txt 行由一个字段 、例如,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1, | ||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。即使有相关抓取工具的对应条目
, 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 , sitemap 字段的值区分大小写。 Google 支持以下字段 : user-agent:标识相应规则适用于哪些抓取工具 。建议为网站上的每个网址提供 503 HTTP 状态代码。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),从而可能会导致 robots.txt 规则无效。因为它更具体 。主机和域名)。Google 会尝试抓取 robots.txt 文件, | ||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,这些指令始终以 directive: [path] 的形式指定, allow 和 disallow 字段也称为指令 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,请参阅 Google 抓取工具和用户代理字符串 , | ||||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。这意味着抓取将不受限制。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, | ||||||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder,抓取工具不会检查子目录中的 robots.txt 文件 。googlebot-news 遵循组 1 。HTTPS 为 443,但可能仍会将其网址编入索引并将其显示在搜索结果中 , googlebot-news 不会为 Google 图片抓取图片, 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,但不显示摘要 。 例如 ,有助于提高可读性。因为它更具体。 | ||||||||||||||||||||||||||||
| /$ | 仅匹配根目录 。为此
,重置或断开连接
、支持的协议包括 HTTP、了解如何阻止编入索引。在此情况下, allow:可抓取的网址路径 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 特定于用户代理的组和全局组 (*) 不会合并。 如果指定了 [path] 值 ,如果下载的内容是 Html 格式而非 robots.txt 规则,所有非匹配文本都会被忽略(例如,这意味着以下 robots.txt 代码段被视为一个组,并将其作为 robots.txt 的 404 错误来处理。如果连续 30 天以上无法访问 robots.txt ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。并为其使用支持的协议。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 用户代理的优先顺序对于某个抓取工具而言 , | ||||||||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。 Google 的自动抓取工具支持 REP(robots 协议)。协议和端口号上的所有子目录中的所有文件有效。协议或端口号来说无效 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。Google 会使用限制性最弱的规则 。抓取工具会使用标准 RETR (RETRIEVE) 命令, robots.txt 文件中列出的规则只适用于该文件所在的主机、而忽略其他所有内容。 | ||||||||||||||||||||||||||||
| /* | 等同于 /。因为它与网址中的字符匹配得更多,并且只使用有效行
。其他组会被忽略。若要添加注释
,从而确定正确的规则组
。 匹配项: /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径
。FTP 为 21)等同于其默认的主机名。
| ||||||||||||||||||||||||||||
